Неверно указан владелец единицы для отчетов

У меня нет процедуры обработки заполнения модуля объекта справочника Номенклатура.
Может я не туда смотрю, но у меня только две процедуры:
Перем мСписокВозможныхРеквизитов Экспорт;
Перем мРеквизитыКонтрольУникальности Экспорт;
Перем мЭтоНеНовый;
// Обработчик события элемента ПриКопировании.
//
Процедура ПриКопировании(ОбъектКопирования)
Если Не ЭтоГруппа Тогда
ЕдиницаХраненияОстатков = Неопределено;
ЕдиницаДляОтчетов = Неопределено;
ЕдиницаИзмеренияМест = Неопределено;
ОсновноеИзображение = Неопределено;
НазначениеИспользования = Неопределено;
КонецЕсли;
КонецПроцедуры // ПриКопировании()
// Обработчик события ПередЗаписью формы.
//
Процедура ПередЗаписью(Отказ)
Если мЭтоНеНовый = Неопределено Тогда
мЭтоНеНовый = Не ЭтоНовый();
КонецЕсли;
Если Не ОбменДанными.Загрузка И Не ЭтоГруппа Тогда
Если Не Услуга И НЕ ЗначениеЗаполнено(БазоваяЕдиницаИзмерения) Тогда
#Если Клиент Тогда
РаботаСДиалогами.СообщитьПользователюНезаполненРеквизит(Ссылка, «базовая единица»);
#КонецЕсли
Отказ = Истина;
Иначе
// Надо проверить владельца единицы хранения остатков.
Если ЗначениеЗаполнено(ЕдиницаХраненияОстатков)
И ЕдиницаХраненияОстатков.Владелец <> Ссылка Тогда
ТекстСообщения = «У единицы хранения остатков номенклатуры «»» + СокрЛП(Ссылка) + «»» неверно указан владелец!»;
ОбщегоНазначения.СообщитьОбОшибке(ТекстСообщения, Отказ);
КонецЕсли;
КонецЕсли;
Если НЕ ЗначениеЗаполнено(ЕдиницаДляОтчетов) Тогда
ЕдиницаДляОтчетов = ЕдиницаХраненияОстатков;
КонецЕсли;
// Надо проверить владельца единицы для отчетов.
Если ЗначениеЗаполнено(ЕдиницаДляОтчетов)
И ЕдиницаДляОтчетов.Владелец <> Ссылка Тогда
ТекстСообщения = «У единицы для отчетов номенклатуры «»» + СокрЛП(Ссылка) + «»» неверно указан владелец!»;
ОбщегоНазначения.СообщитьОбОшибке(ТекстСообщения, Отказ);
КонецЕсли;
Если мЭтоНеНовый Тогда
СуществуютСсылки = Неопределено;
Если Не Услуга И Ссылка.ЕдиницаХраненияОстатков <> ЕдиницаХраненияОстатков И ПолныеПрава.Номенклатура_СуществуютСсылки(Ссылка, СуществуютСсылки) Тогда
ТекстСообщения = «Единица «»» + СокрЛП(Ссылка.ЕдиницаХраненияОстатков) + «»» является единицей хранения остатков для «»» + Наименование + «»»
|и уже участвует в товародвижении.
|Изменить эту единицу уже нельзя!»;
ОбщегоНазначения.СообщитьОбОшибке(ТекстСообщения, Отказ);
КонецЕсли;
Если (Услуга <> Ссылка.Услуга Или Комплект <> Ссылка.Комплект Или Набор <> Ссылка.Набор)
И ПолныеПрава.Номенклатура_СуществуютСсылки(Ссылка, СуществуютСсылки) Тогда
ТекстСообщения = «Номенклатура «»» + СокрЛП(Ссылка) + «»» участвует в товародвижении.
|Нельзя изменить тип номенклатуры (Услуга, товар, набор-комплект), если позиция номенклатуры участвует в товародвижении!»;
ОбщегоНазначения.СообщитьОбОшибке(ТекстСообщения, Отказ);
КонецЕсли;
Если Не ВестиУчетПоСериям И Ссылка.ВестиУчетПоСериям И ПолныеПрава.Номенклатура_СуществуютСсылкиНаСерииВРегистрахНакопления(Ссылка) Тогда
ТекстСообщения = «Номенклатура «»» + СокрЛП(Ссылка) + «»» участвует в товародвижении.
|признак учета по сериям не может быть изменен!»;
ОбщегоНазначения.СообщитьОбОшибке(ТекстСообщения, Отказ);
КонецЕсли;
КонецЕсли;
Если НЕ ЗначениеЗаполнено(ВидНоменклатуры) Тогда
#Если Клиент Тогда
РаботаСДиалогами.СообщитьПользователюНезаполненРеквизит(Ссылка, «вид номенклатуры»);
#КонецЕсли
Отказ = Истина;
КонецЕсли;
Если НЕ Отказ Тогда
Если Не ВестиУчетПоСериям Тогда
Если ЗначениеЗаполнено(НомерГТД) Тогда
НомерГТД = Справочники.НомераГТД.ПустаяСсылка();
КонецЕсли;
Если ЗначениеЗаполнено(СтранаПроисхождения) Тогда
СтранаПроисхождения = Справочники.КлассификаторСтранМира.ПустаяСсылка();
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецПроцедуры // ПередЗаписью()

Файл:

Дошел до заполения ячеек табличного поля СправочникСписок в форме списка справочника при изменении одной из ячеек. Зачем получать из регистра? не понял? На следующем скриншоте изображена таблица «Товары» из документа 1С. Таблицу документа называют «табличная часть». Это значит, что запросив поле Наименование из справочника Номенклатура, Вы получите колонку вида Строка с допустимой длиной не более Иногда возникает необходимость вывода в табличное поле документа (или любого другого объекта, имеющего табличную часть) дополнительных колонок с данными, которые не содержатся непосредственно в табличной части. Шаблоны кода. Общего назначения. Настройка вывода на печать табличного документа в 1С:Предприятие 8. ТабДок.КоличествоЭкземпляров=5; Разумеется, можно задать поля Табличную часть формы объекта можно получить через объект ЭлементыФормы: Объект ЭлементыФормы используется для доступа к элементам управления, расположенным на КонецЕсли; КонецЦикла; Результат для документа Авансовый отчет: Это табличное поле!! Выбираете табличный документ (в настройках обработки можно указать, что требуется предпросмотр табличного документа, в этом случае на форму будет выведо поле табличного документа). Нажимаете кнопку «Получить таблицу данных». 1.2 табличный документ: 1.3 произвольные файлы (двоичные данные): 1.4 внешние обработки и отчеты: 1.5 Работа с хранилищем. 2.3.6 Получение файла из информационной базы. 2.3.7 Пример использования файловых методов. 2.3.8 Поддержка адресов в поле В таблице DTххх — хранятся данные реквизитов табличной части (каждый реквизит минимум одно поле таблицы плюс системное поле LINENO_ — номер строки документа). Работать с табличными частями конкретного объекта можно так: Посмотрите здесь: Заполнение табличной части одного документа из табличной части другого документа 1С 1C 8.x 1С Поле выбора в табличной части Подстановка реквизита элемента Получить поле табличного документа, в которое будем выводить результат. Запись общего итога всегда одна, поэтому можно обойтись без организации цикла. Вывод картинки. Изменение шрифта (жирность) при выводе табличной части формы. Отбор в табличном поле формы. ОтборСтрок. Прочее. Получение файла через HTTP-соединение. Получить таблицу подчинённых документов. Регистры накопления. СКД. Вывод картинки. Изменение шрифта (жирность) при выводе табличной части формы. Отбор в табличном поле формы. ОтборСтрок. Прочее. Получение файла через HTTP-соединение. Получить таблицу подчинённых документов. Регистры накопления. СКД. В системе поддерживается механизм расшифровок, который позволяет пользователю получить детальный или дополнительный отчет, щелкнув мышью на строке или ячейке табличного документа. Рассмотрим свойства и методы табличного документа, относящиеся к настройкам печати. Число копий можно указать так: ТабДок.КоличествоЭкземпляров=5; Разумеется, можно задать поля Фиксированная коллекция значений полей данных, полученных табличным полем от поставщика данных. Строка вида «Справочник.», «Документ.» и т.д., без имени поля и знака «$». Описание

Ампельные растения, например, настурция, Активатор 7 инструкция, Доклад на тему сельское хозяйство швеции, Pocket navigator mw 350 инструкция, Примеры vb логические операторы.

В теме форма: v8: Получение данных из ХралищаЗначений

Bell в управляемом интерфейсе пробует сохранить выбранные картинки в базу 1С, но возникли сложности с сохранением в хранилище значений. как пример Bell приложил CF файл с мини конфигурацией, за что ему большое спасибо, т.к. большая часть материалов этой статьи написана им, я лишь поправил небольшие участки кода связанные с передачей файлов и сохранение в хранилище значений.

Так как везде уже Такси, то CF я перевел в этот режим и в нем демонстрирую.

Имеется справочник Хранилище данных:

Основная Форма Элемента:

Ее код:

Код 1C v 8.3 // ПРОЦЕДУРЫ ФОРМЫ
//======================================================================================================
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Если Объект.Ссылка.Пустая() Тогда
Объект.Наименование = «.»;
КонецЕсли;
Если НЕ Параметры.Ключ.Пустая() Тогда
ДанныеАдрес = ПолучитьНавигационнуюСсылку(Объект.Ссылка, «ДанныеХЗ»);
КонецЕсли;
КонецПроцедуры
&НаКлиенте
Процедура ПриОткрытии(Отказ)
Если Объект.Ссылка.Пустая() Тогда
КонецЕсли;
КонецПроцедуры
&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
Если ЭтоАдресВременногоХранилища(ДанныеАдрес) Тогда
РежимСжатия = Новый СжатиеДанных(9);
ДанныеСохранения = ПолучитьИзВременногоХранилища(ДанныеАдрес);
ТекущийОбъект.ДанныеХЗ = Новый ХранилищеЗначения(ДанныеСохранения, РежимСжатия);
КонецЕсли;
КонецПроцедуры
&НаСервере
Процедура ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
Если ЭтоАдресВременногоХранилища(ДанныеАдрес) Тогда
УдалитьИзВременногоХранилища(ДанныеАдрес);
ДанныеАдрес = ПолучитьНавигационнуюСсылку(ТекущийОбъект.Ссылка, «ДанныеХЗ»);
КонецЕсли;
КонецПроцедуры
// ПРОЦЕДУРЫ ЭЛЕМЕНТОВ ФОРМЫ
//======================================================================================================
&НаКлиенте
Процедура ВыбратьДанные(Команда)
ДанныеВыбрать();
КонецПроцедуры
&НаКлиенте
Процедура СохранитьДанные(Команда)
Если НЕ ЗначениеЗаполнено(Объект.Ссылка) Тогда
Предупреждение(НСтр(«ru = ‘Элемент не записан !!!'»));
Возврат;
КонецЕсли;
ДанныеСохранения = ПолучитьНавигационнуюСсылку(Объект.Ссылка, «ДанныеХЗ»);
ИмяСохранения = Объект.Наименование;
//ИмяСохранения = Объект.Наименование + Объект.ДанныеРасширение;
ПолучитьФайл(ДанныеСохранения, ИмяСохранения, Истина);
КонецПроцедуры
// ПРОЦЕДУРЫ ПРОЧИЕ
//======================================================================================================
&НаКлиенте
Процедура ДанныеВыбрать()
ПолученныеДанныеАдрес = «»;
Если ПоместитьФайл(ПолученныеДанныеАдрес, , Объект.ДанныеПуть, Истина, УникальныйИдентификатор)Тогда
ДанныеАдрес = ПолученныеДанныеАдрес;
ВыбранныйФайл = Новый Файл(Объект.ДанныеПуть);
Объект.Наименование = ВыбранныйФайл.Имя;
Объект.ДанныеТекущаяДата = ТекущаяДата();
Модифицированность = Истина;
КонецЕсли;
КонецПроцедуры

так же имеется общая форма ФормаЗагрузкиФайлов

При помощи ее выбираются файлы изображений и загружаются в справочник — одновременно можно загружать несколько файлов

код формы:

Код 1C v 8.3 // ПРОЦЕДУРЫ ЭЛЕМЕНТОВ ФОРМЫ
//======================================================================================================
&НаКлиенте
Процедура СписокФайловПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа)
Отказ = Истина;
ДобавитьФайлы();
КонецПроцедуры
// ПРОЦЕДУРЫ ПРОЧИЕ
//======================================================================================================
&НаКлиенте
Процедура ДобавитьФайлы()
ВыборФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
ВыборФайла.МножественныйВыбор = Истина;
ВыборФайла.Заголовок = НСтр(«ru = ‘Выбор файла'», «ru»);
ВыборФайла.Фильтр = НСтр(«ru = ‘Все файлы'», «ru») + » (*.*)|*.*»;
ВыборФайла.ПредварительныйПросмотр = Истина;
Если ВыборФайла.Выбрать() Тогда
Для каждого СтрокаФайл Из ВыборФайла.ВыбранныеФайлы Цикл
ОписаниеФайла = Новый Файл(СтрокаФайл);
НВС = СписокФайлов.Добавить();
НВС.ПолноеИмяФайла = СтрокаФайл;
НВС.РазмерФайла = ОписаниеФайла.Размер();
КонецЦикла;
КонецЕсли;
КонецПроцедуры
&НаКлиенте
Процедура Загрузить()
Если НЕ ПроверитьЗаполнение() Тогда
Возврат;
КонецЕсли;
ОчиститьСообщения();
Если СписокФайлов.Количество() = 0 Тогда
Сообщить(«Файлы не выбраны !!!'»);
Возврат;
КонецЕсли;
ПомещаемыеФайлы = Новый Массив;
Для каждого СтрокаФайл Из СписокФайлов Цикл
Описание = Новый ОписаниеПередаваемогоФайла(СтрокаФайл.ПолноеИмяФайла, «»);
ПомещаемыеФайлы.Добавить(Описание);
КонецЦикла;
// ——————————————————————————-
ПомещенныеФайлы = Новый Массив;
СписокЗагруженныхФайлов = Новый СписокЗначений;
Если ПоместитьФайлы(ПомещаемыеФайлы, ПомещенныеФайлы, , Ложь, УникальныйИдентификатор) Тогда
Закрыть(Истина);
Иначе
Сообщение = Новый СообщениеПользователю();
Сообщение.Текст = НСтр(«ru = ‘Файлы не загружены'», «ru»);
Сообщение.Сообщить();
КонецЕсли;
ОповеститьОВыборе(ПомещенныеФайлы);
КонецПроцедуры
&НаСервере
Функция ПоместитьВыбранныеФайлыВХранилище(ПомещаемыеФайлы)
АдресХЗ = ПоместитьВоВременноеХранилище(ПомещаемыеФайлы, УникальныйИдентификатор);
Возврат АдресХЗ;
КонецФункции

в коде вызывается ОповеститьОВыборе(ПомещенныеФайлы) и срабатывает обработчик в ФормаСпискаДополнительно

Код 1C v 8.3 &НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
Если ИсточникВыбора.ИмяФормы = «ОбщаяФорма.ФормаЗагрузкиФайлов» Тогда
ОбработкаВыбораПодборНаСервере(ВыбранноеЗначение);
КонецЕсли;
КонецПроцедуры

и следующим кодом идет создание элементов справочника и загрузка изображений из временного хранилища

Код 1C v 8.3 &НаСервере
Процедура ОбработкаВыбораПодборНаСервере(ВыбранноеЗначение)
Для Каждого СтрокаФайл Из ВыбранноеЗначение Цикл
Файл = Новый Файл(СтрокаФайл.Имя);
ХранимыйФайл = Справочники.ХранилищеДанныхСправочники.СоздатьЭлемент();
ХранимыйФайл.Наименование = Файл.Имя;
ХранимыйФайл.ДанныеПуть = Файл.Путь;
ХранимыйФайл.ДанныеТекущаяДата = ТекущаяДата();
ХранимыйФайл.ДанныеХЗ = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(СтрокаФайл.Хранение), Новый СжатиеДанных());
ХранимыйФайл.Записать();
КонецЦикла;
Элементы.Список.Обновить();
КонецПроцедуры